Ausfall TP-Link TL-WR841N


#1

Hallo zusammen,

ich habe hier permanent Ausfälle meiner TP-Link TL-WR841N Router. Hat das was mit dem Freifunk Netz zu tun? Ein Neustart des Routers hinter der fritzbox muss beinahe wöchentlich erfolgen


#2

Hallo,
das sollte natürlich nicht passieren, um dir weiterzuhelfen bräuchte ich noch ein paar Infos:

  • Welche Art von Ausfällen hast du? Leuchten die LED am Freifunk Router, wenn er nicht funktioniert? Wenn ja, welche?
  • Welche Firmware-Version nutzt du?
  • Wie verbindet sich der Freifunk-Router mit dem Internet/VPN?
  • Welchen Internetanschluss nutzt du?

Ein Screenshot von der Info-Seite deines Routers wäre ebenfalls hilfreich, dazu verbindest du dich mit deinem Freifunk-Netz und gibst im Browser 10.37.0.1 ein. IP-Adressen, Router-Name etc. kannst du schwärzen wenn du möchtest.

Viele Grüße
Manuel


#3

Hallo,

du hast auf die Mail-Benachrichtigung geantwortet - das ist kein Problem, jedoch wird das momentan noch nicht ins Forum übertragen. Um Probleme und deren Lösungen auch für andere Zugänglich zu machen, zitiere ich deine Nachricht mal hier, ich hoffe das ist okay:

Hallo Manuel,

danke für die Unterstützung.

Alle Led’s sind wie im normalen Betrieb aktiv.

Der Freifunkrouter verbindet sich über eine Fritzbox mit dem Internet (KabelDeutschland/Vodafone).

Die Fritzbox steigt gerne mal aus, bzw. hatte ich auch mit Kabeldeutschland in letzter Zeit Probleme.

Sobald meine Internetverbindung sich wieder etabliert, muss der Freifunkrouter neugestartet werden. Bis ich dies bemerke vergehen dann manchmal ein paar Tage.

Es kam aber auch vor (in den letzten paar Monaten), das plötzlich die internetverbindung über freifunk nicht hergestellt werden konnte. Dies bemerkte ich über mein Smartphone, das dann auf LTE wechselte.

Irgendwo habe ich noch einen Dlink Router. Den werde ich mal testweise als Fritzbox Ersatz nutzen.

Nach einer Störung der WAN-Verbindung des Freifunk-Knotens sollte dieser sich eigentlich wieder selbstständig mit einem Gateway verbinden, das scheint bei dir aktuell nicht zu funktionieren.

Woran das liegt kann ich dir momentan nicht sagen, bin aber gerade dabei eine neue Firmware-Version zu erstellen. Sobald das abgeschlossen ist, würde ich dich bitten diese aufzuspielen und zu schauen, ob das Problem damit behoben wird.


#4

Hallo Manuel,

auch ich habe hier massive Aussetzer beim TP-Link TL-WR841N/ND v9.
Davon fallen 3 mehrmals täglich aus, rebooten manchmal eigenständig und sind dann wieder im Netz sichtbar.
Und zwar fällt immer wieder nur das WLAN aus. Dadurch sind dann alle Bingerbrücker Router, auch der Waschbär offline.
Wenn du mal einen von den 3 Router “tracken” willst: https://map.freifunk-mainz.de/#!v:m;n:30b5c223122a
Auf allen Router ist drauf: 0.8.1-stable / gluon-v2016.1.5-6-g11d8070
Diese WLAN-Ausfälle konnte ich seit der Ver. 0.8.0 feststellen…
Beim Router: https://map.freifunk-mainz.de/#!v:m;n:c46e1f7eb552 kann man die Ausfälle auch gut verfolgen,
der ist per LAN mit den anderen Freifunkrouter verbunden.
VG
Stefan


#5

Okay, könntet ihr vielleicht ein manuelles Firmware-Update durchführen?

Das wäre die Firmware: http://mettbroetchen.freifunk-bingen.de/gluon-ffbin-0.8.2-stable-tp-link-tl-wr841n-nd-v9-sysupgrade.bin
Für TP-Link WR841n/nd v9

Am Schnellsten geht’s via SSH auf dem Knoten:

cd /tmp/
wget http://mettbroetchen.freifunk-bingen.de/gluon-ffbin-0.8.2-stable-tp-link-tl-wr841n-nd-v9-sysupgrade.bin
echo 3 > /proc/sys/vm/drop_caches
sysupgrade gluon-ffbin-0.8.2-stable-tp-link-tl-wr841n-nd-v9-sysupgrade.bin

Oder alternativ natürlich auch im Config-Modus.


#6

Hallo Manuel,

habe die 0.8.2-staple auf den ffbin5-Germaniablick.de https://map.freifunk-mainz.de/#!v:m;n:30b5c223122a aufgespielt.
Nun mal schauen, wie der läuft…beim booten ist auch zufällig der ffbin1-Germaniablick.de abgeschmiert. Nun haben beide das gleiche Zeitdatum beim “Uptime”.
–> kann man schön vergleichen.
Viele Grüße


#7

Super, danke. Bin gespannt, konnte es mir noch nicht zu 100% anschauen, aber es scheint tatsächlich Probleme mit der alten Firmware zu geben, habe einen Router mit ähnlichen Symptomen, läuft mit 0.8.2 allerdings stabil.


#8

So,
da auch hier ständig der zweite 841 ausgefallen ist, habe ich eben den ffbin3-Germaniablick.de https://map.freifunk-mainz.de/#!v:m;n:c46e1f7eb552 mit der neuen 0.8.2-staple versorgt. Immer wenn dieser Router im Freifunknetz ausfällt, hat auch der Kirchturm und der Waschbär kein Netz. (wahrscheinlich ist dort der Uplink auch ausgefallen)
Was auch auffällt… es fallen immer nur die Router aus, bei denen mal ne beta drauf war, also wo von “Hand” die Betriebssoftware aufgespielt wurden. Da der “Monitormode” nun auch in der staple drin ist, habe ich alle Router auf 0.8.1. staple umgestellt…eigentlich sind alle gleich.
Nun mal weiter beobachten…


#9

Wolfgang hat jetzt wieder von problemen berichtet, hat sonst noch jemand ausfälle? Die 0.8.2 ist ja noch nicht raus…daher kann es am treiber liegen


#10

Hatte auch eben Probleme, keine IPv4 bekommen. Router neugestartet, dann ging es.
Ich versuche rauszufinden, woran es liegt!


#11

Naja, dann hau ich die Firmware heute oder morgen mal raus.


#12

Hallo Ruben,
ja, die Ausfälle mit der Version 0.8.2-stable habe ich immer noch; anbei meine Beobachtungen:
Hier habe ich nur die Router TL-WR841N/ND v9 im Einsatz; 2x mit 0.8.2-stable, den Rest mit 0.8.1-stable.
So wie ich das beobachte fällt mind. einmal täglich das WLAN aus; wenn dies passiert sind die Router mit 0.8.2-stable jedoch innerhalb 15 min wieder “online”, die Router mit 0.8.1-stable manchmal bis zu 24h offline. Der WAN-Port funktioniert immer. Die Ausfälle habe ich seit der 0.8.0-stable. Fällt ein Router aus, ist meistens innerhalb 4 Stunden der nächste (der im “nahen” Umfeld steht) auch offline.
…und das ganze passiert anscheinend nur wenn die Router im WLAN-Umkreis von unter 20m stehen. Wenn die Entfernung größer ist, kann ich eigentlich keinen Ausfall (egal welche Version) beobachten.
Router mit der 0.8.2-stable, die keinen anderen Freifunkrouter in Reichweite haben, also nur über VPN online gehen, sind machmal erst nach 12h auf der Karte sichtbar.
VG
Stefan


#13

Hast du die Möglichkeit dich via SSH auf die Router einzuloggen, ohne sie vorher neuzustarten? Also über die LAN-Verbindung?

Interessant wären die letzten Einträge vom Befehl:

logread

#14

SSH hatte ich nicht aktiviert…Router hängt am Dachfirst --> komme da nicht so gut ran !
Aber beim Router: ffbin3-Germaniablick.de https://map.freifunk-mainz.de/#!v:m;n:c46e1f7eb552 kann ich das einrichten, das ginge gut. Aber aktuell ist wieder das WLAN ausgefallen, selbst mit der neuen Version 0.8.2-stable :frowning:
Deshalb ist aktuell alles in Bingerbrück wieder “rot”…


#15

Morgen, ich habe mal den ffbin_PreTest ins Netz gestellt, 841er v10 mit 0.8.2 drauf und Manuels und Olivers SSH Key, wenn ihr mal drauf schauen wollt. im momemt ist er nur im Mesh, ich kann ihn auch direkt ans VPNMesh hängen, wenn das hilft.


#16

So, habe nun beide Router neu gestartet und SSH drauf eingerichtet. Dann schauen wir mal die Tage, was das Log hergibt…


#17

Hallo Manuel,

so, habe die Logfiles ziehen können.
Im Moment ist der ffbin3-Germaniablick.de https://map.freifunk-mainz.de/#!v:m;n:c46e1f7eb552 wieder ausgefallen und nur noch per LAN erreichbar. Ich habe ihn noch nicht neu gebootet, sondern erst das Logfile rauskopiert.
(hochladen kann ich es hier nicht --> ist nicht erlaubt)
Ich schicke die Textdatei an euer Freifunk-Postfach.

Gruß
Stefan


#18

Hi,

danke für die Logfiles, folgendes ist das Problem:

Wed Nov 30 19:12:03 2016 daemon.info fastd[1403]: resolving host 'lotuswurzel.freifunk-mwu.de' for peer <mesh_vpn_backbone_peer_lotuswurzel>...
Wed Nov 30 19:12:03 2016 daemon.info fastd[1403]: resolving host 'lotuswurzel.freifunk-mwu.de' failed: Name or service not known
Wed Nov 30 19:12:05 2016 daemon.info fastd[1403]: resolving host 'kaschu.freifunk-mwu.de' for peer <mesh_vpn_backbone_peer_kaschu>...
Wed Nov 30 19:12:05 2016 daemon.info fastd[1403]: resolving host 'kaschu.freifunk-mwu.de' failed: Name or service not known
Wed Nov 30 19:12:07 2016 daemon.info fastd[1403]: resolving host 'spinat.freifunk-mwu.de' for peer <mesh_vpn_backbone_peer_spinat>...
Wed Nov 30 19:12:07 2016 daemon.info fastd[1403]: resolving host 'spinat.freifunk-mwu.de' failed: Name or service not known
Wed Nov 30 19:12:07 2016 daemon.info fastd[1403]: resolving host 'wasserfloh.freifunk-mwu.de' for peer <mesh_vpn_backbone_peer_wasserfloh>...
Wed Nov 30 19:12:07 2016 daemon.info fastd[1403]: resolving host 'wasserfloh.freifunk-mwu.de' failed: Name or service not known

Der Knoten ‘ffbin3-Germaniablickde’ kann die Gateways nicht erreichen, da die Hostnamen nicht aufgelöst werden können. Das deutet auf ein Problem mit den Netzwerkeinstellungen oder mit deinem Internet-Router hin.
Kannst du mir noch sagen was bei

uci show gluon-wan-dnsmasq

rauskommt?

Testweise kannst du mal einen anderen DNS-Server einsetzen, z.B. Google-Public-DNS, evtl. löst das bereits das Problem:

uci add_list gluon-wan-dnsmasq.@static[0].server=8.8.8.8
uci commit gluon-wan-dnsmasq
/etc/init.d/dnsmasq restart

#19

Hallo Manuel,

du hast die Logfiles vertauscht.
Den Textauszug von oben ist vom ffbin1-Germaniablick.de und der läuft ja !

Probleme mit den Netzwerkeinstellungen…beide Router sind nicht mit der Fritzbox (Internet) verbunden;
sie sind nur per LAN “Rücken an Rücken” verbunden.

Der ausgefallene Router war der ffbin3-Germaniablick.de, bei dem das WLAN ausfällt.
Seltsamerweise ist er ohne zu booten, seit heute morgen wieder online.
Davon schicke ich dir nochmal die Logfiles.


#20

Hi,

sorry, hab ich durcheinandergewürfelt.

Sag mir bitte mal den genauen Aufbau von ffbin1-G… und ffbin3-G… - also in welchem Port ein Kabel zu welcher Gegenstelle angeschlossen ist und ob du Netzwerkeinstellungen wie Mesh-on-WAN eingestellt hast.

Bei ffbin1-G könntest du mal VPN abschalten, der versucht sich ständig mit den Gateways zu verbinden, hat aber ja scheinbar kein Internet:

/etc/init.d/fastd stop
uci set fastd.mesh_vpn.enabled=0
uci commit fastd